Nithrox - Project access, updating and creation impacted in us-east-2 – Incident details
All systems operational
Project access, updating and creation impacted in us-east-2
Resolved
Major outage
Started 11 days agoAugust 14, 2026Lasted about 1 hourAugust 14, 20269:3110:44 AMUTC
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
A fix has been applied to all impacted projects in us-east-2. We are monitoring for full resolution.
Update
UTC
Update
UTC
A fix is being rolled out and we are seeing improved performance across impacted projects. We are continuing to roll out the full fix and will be confirming recovery asap.
Identified
UTC
Identified
UTC
We are investigating an issue of project creation and updating in us-east-2. A fix is under review and prepared for being rolled out.